Task
Given a Book class and a Solution class, write a MyBook class that does the following:
- Inherits from Book
- Has a parameterized constructor taking these 3 parameters:
- string title
- string author
- int price
- Implements the Book class’ abstract display() method so it prints these lines:
- Title:, a space, and then the current instance’s title.
- Author:, a space, and then the current instance’s author.
- Price:, a space, and then the current instance’s price.
Note: Because these classes are being written in the same file, you must not use an access modifier (e.g.:public ) when declaring MyBook or your code will not execute.
Input Format
You are not responsible for reading any input from stdin. The Solution class creates a Book object and calls the MyBook class constructor (passing it the necessary arguments). It then calls the display method on the Book object.
Output Format
The void display() method should print and label the respective title, author, and price of the MyBook object’s instance (with each value on its own line) like so:
Title: $title
Author: $author
Price: $price
Note: The $ is prepended to variable names to indicate they are placeholders for variables.
Sample Input
The following input from stdin is handled by the locked stub code in your editor:
The Alchemist
Paulo Coelho
248
Sample Output
The following output is printed by your display() method:
Title: The Alchemist
Author: Paulo Coelho
Price: 248
Solutions:
1)Javascript:
'use strict';
var _input = '';
var _index = 0;
process.stdin.on('data', (data) => { _input += data; });
process.stdin.on('end', () => {
_input = _input.split(new RegExp('\n'));
main();
});
function readLine() { return _input[_index++]; }
/**** Ignore above this line. ****/
class Book {
constructor(title, author) {
if (this.constructor === Book) {
throw new TypeError('Do not attempt to directly instantiate an abstract class.');
}
else {
this.title = title;
this.author = author;
}
}
display() {
console.log('Implement the \'display\' method!')
}
}
class MyBook extends Book{
constructor(title,author,price){
super(title,author);
this.price = price;
}
display(){
console.log("Title:",this.title);
console.log("Author:",this.author);
console.log("Price:",this.price);
}
}
function main() {
let title = readLine()
let author = readLine()
let price = +readLine()
let book = new MyBook(title, author, price)
book.display()
}
2)Java:
import java.util.*;
abstract class Book {
String title;
String author;
Book(String title, String author) {
this.title = title;
this.author = author;
}
abstract void display();
}
class MyBook extends Book{
private int price;
MyBook(String title,String author,int price){
super(title,author);
this.price=price;
}
public void display(){
System.out.println("Title: "+this.title);
System.out.println("Author: "+this.author);
System.out.println("Price: "+this.price);
}
}
public class Solution {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
String title = scanner.nextLine();
String author = scanner.nextLine();
int price = scanner.nextInt();
scanner.close();
Book book = new MyBook(title, author, price);
book.display();
}
}